top of page

Gruppe

Öffentlich·14 Mitglieder
Vitali Socks
Vitali Socks

Mtk6589 Preloader



Sometimes you might need to get some data from UART on downstream kernel (for example, with intention to debug boot process of your pmOS port) but it's been automatically disabled by the preloader or UBoot or something else. One of the solutions suggested by the official MediaTek OEM FAQ is to run this command as early as possible:




mtk6589 preloader



Thanks for the tutorial. My Mediatek Phone is totally dead. No signs of any life. I can only feel the warmth while i connect it to the charger. But no lights are displayed. When i connect the USB it shows as Mediatek USB port in the device manager. But cannot flash anything including the preloader. What could be the problem? Please advice. Thanks and God bless.


Dear sir, I have tried all your methods.My Pc Detect My Phone as preloader usb vcom port, I am using windows 8.1 64 bit, no issue with driver software and sp flash tool. Is it any problem with my Motherboard.my phone model is alpas technician jelly been 89 MTK 6589. I always got "BROM ERROR : S_FT_ENABLE_DRAM_FAIL (4032) " after flashing device (during flashing after 10 seconds i always got this message).


mine happened the same as you. flashed the wrong preloader, yada2 this and that, still no luck. backing up from another source of the same model wouldn't give luck to restore the phone and wondering why the same model couldn't flash the preloader. and my rom is only 1.5 instead of 4. and when i checked it, it is a clone. and i have to go to the store back and/or create a backup first of my current phone to get the only preloader for the phone. if you're lucky you can get back the preloader from somewhere. try to look hard for it and try flashing EVERY rom, and follow the steps as secured by MonsterDroid.


Rodrigo make sure that your device is getting detected in the Device manager it will be something like MTK(some numbers), and be sure that the drivers are properly installed, download your STOCK Rom with proper preloader and scatter files then flash it, there will sometime come a situation when the PC will detect the device only for few seconds,(keep the volume of the PC at highest to hear when the device is connected and getting disconnected and note the duration), then meantime without the battery you connect the device and flash the ROM via SP tool if everything will go good then you will get the green circle!! good luck,


i) used the s920_row_s117. completed.ii) cannot turn on. power button and everything is a no goiii) downloaded several ones, but to no avail.iv) kept getting the error dram problem.v)installed mtk6589 drivers over and over again, installing lenovousbdrivers over and over again for 8 hours while tryingvi) followed this guide. vol+, vol-, vol+power, vol-power, nothing. and now the drivers are gone. i need to restart pc for no reason.


yea. i saw one in the youtube not to mess with the preloader as it is different if its a clone. and the best thing is i flashed the preloader the same as other components to flash!!! that is my mistake. the only preloader that my phone will accept is from the supplier itself, not the stock roms. it is very different to flash lenovo than to flash all other like samsung and sony. so i will never mess with this again.


you need the correct preloader for your phone Orangzaib. If not, it will always say dram failed to be enabled. the only problem that it is causing, comes from the preloader. if it is a clone, you have no other choice but to send it back to the supplier, and that happened to me. not all clones are the same, and not all clones have the same preloader. you should check whether it is a clone or not. the MTK USB port is not the problem. all of them is MTK USB Port, and if the preloader is correct, it will change to MTK USB VCOM something when succeeded. never to flash preloader again! just flash any other components but NOT preloader!


GreetingsI have a Maxwest Orbit 3000 (unrooted) running Android 4.2.2 / MTK6572I tried to format with the wrong preloader and now I also have the BROM ERROR: S_FT_ENABLE_DRAM_FAIL (4032)Finally found the correct stock ROM but the phone is dead. Also when I plug it into the computer I get the "Device not recognized" error.Tried your above suggestions (power+vol up / power+vol down), still the same result. Would appreciate any other ideas you have. Thanks


Info

Willkommen in der Gruppe! Hier können Sie sich mit anderen M...

Mitglieder

Gruppenseite: Groups_SingleGroup
bottom of page